Accueil : Physique - Chimie
Accueil >> OpenOffice...

article OpenOffice Calc : perfectionnement     -    publié le 03/02/2002    mis à jour le 25/04/2018

• OpenOffice : perfectionnement.

L’utilisation la plus banale de ce tableur étant supposée acquise (notion de cellule, de formule, graphe) les indications qui suivent permettent de progresser dans l’utilisation de ce tableur très puissant.
L’assistant pour les formules,
La "valeur cible",
La programmation.

• Assistant pour les formules

Lors de l’utilisation de formules très simples (B1 doit contenir le sinus de A1 par exemple) il suffit de taper la formule dans la case considérée pour obtenir le résultat. Par contre, pour des fonctions plus compliquées (voire à priori inconnues !) ou en raison d’une complexité engendrée par l’imbrication de plusieurs fonctions, l’utilisation de l’assistant se révèle quasi indispensable.
Exemple : on veut qu’en B1 il y ait la représentation d’un chiffre hexadécimal (entre 0 et 15) placé en A1. Il faut donc tester si ce nombre est plus petit que 10 (dans ce cas on l’écrit) sinon s’il vaut 10 (dans ce cas on écrit A) et ainsi de suite jusqu’à 15 (dans ce cas on écrit F sinon erreur). Celà donne :
=SI(A1<10 ;A1 ;SI(A1=10 ;"A" ;SI(A1=11 ;"B" ;SI(A1=12 ;"C" ;SI(A1=13 ;"D" ;SI(A1=14 ;"E" ;SI(A1=15 ;"F" ;"erreur")))))))

Pour écrire cette formule il faut connaître la syntaxe de la fonction SI, ne pas oublier de guillemet, de point-virgule ni de parenthèse ! Alors qu’avec l’assistant il suffit de :
cliquer sur fx pour l’appeler,
pour

• test logique

taper A1<10,
pour

• valeur si vrai

taper A1
pour

• valeur si faux

taper à nouveau sur le bouton fx et recommencer comme précédemment.

• Valeur cible

Cet outil permet de faire calculer une cellule en vue d’obtenir le résultat souhaité dans une autre cellule.
Exemple très simple : chercher la racine cinquième de 6.
Ecrire "2" (par exemple) en A1 et "=A1^5" en B1
Au menu, choisir : Outils/Recherche de valeur cible
Compléter le tableau et valider.

Image1
Image2
Image3

L’outil a bien ajusté la valeur de A1 pour qu’il y ait le nombre 6 en B1 !
Exercice :
Un objet étant tombé au fond d’un bassin plein d’eau, de quel angle faut-il incliner la lampe placée à l’aplomb du bord de ce bassin pour l’éclairer ?

bassin
un document La solution (Zip de 13.4 ko)

• La programmation

Image5-2

Dans Outils/Macros on trouve les commandes indispensables à la programmation : Enregistrer une macro qui permet de mémoriser une suite de commandes (écriture automatique d’un programme), Exécuter la macro pour lancer un programme, Gérer les macros et les boîte de dialogues pour programmer directement.
Attention ! ces fonctions nécessitent un environnement java, il faut donc installer un "J.R.E." (fichier à télécharger pour avoir la version la plus récente).
Voici quelques textes d’application :

un document Macro-commandes (PDF de 234.8 ko)
un document Barres d’outil (PDF de 159.6 ko)
un document Boîte de saisie (PDF de 235.1 ko)

Et le classeur que l’on obtient lorsqu’on suit la progression :

code_couleurs
Contact
Accessibilité
Mentions légales
RSS
Académie de Poitiers, Rectorat, 22 rue Guillaume VII le Troubadour BP 625 86022 Poitiers Cedex